wpa_supplicant troubles with connection following authentication (cannot get IP)

Joseph Love joe
Fri Oct 14 22:15:48 PDT 2005

A little more information into the scope of the problem, and why I  
came here before going to the FreeBSD lists:
For several months, many people on campus have been trying to get  
their wireless working under Linux, and have been reporting similar  
results to what I have, which is that it seems to authenticate but  
does not get an ip address from the dhcp server (although, I believe  
all of them were using xsupplicant).  Because of this, I felt that it  
would be more likely that I could find someone who might understand  
the problem better here, than on the freebsd lists.

Now, onto the questions:
I am using FreeBSD 6.0RC1, with wpa_supplicant 0.4.5 (downloaded from  
the hostap website).  The last time I tried 0.3.9, I received similar  
results, and figured that maybe I should try a more recent version.   
The version I tried on windows was also 0.4.5, but was the binary  

A packet dump is available at http://www.getsomewhere.net/ 
uicwireless.dump .  It seems that those LLC packets were for a  
spanning tree protocol.

I find the key config stuff you mentioned interesting.  I wonder if  
there are issues with dynamic wep keying that I am facing.


On Oct 14, 2005, at 10:40 PM, Jouni Malinen wrote:

> On Fri, Oct 14, 2005 at 10:01:38PM -0500, Joe Love wrote:
>> The one comparison between the two connections that has confused  
>> me the
>> most is the output from ethereal.  On both freebsd & windows, I  
>> see the
>> same EAP, TLS & EAPOL protocol packets, but once the EAP succeeds,  
>> and
>> keys are exchanged, the output under windows looks like normal  
>> traffic,
>> including one Ethernet II packet, followed by a DHCP request,
>> acknowledgement, and arp traffic (and some other stuff).  Under  
>> FreeBSD,
>> however, I see the keys exchanged, and then a bunch of packets of
>> protocol type "LLC", and the only packets that aren't LLC are ones  
>> that
>> come from my machine.  I see no typical IP traffic from any other  
>> hosts.
> This sounds very much like the driver you are using would not be
> decrypting frames correctly. Which driver and wlan hardware model are
> you using? Is this with wpa_supplicant from the FreeBSD 6.0  
> snapshot/RC
> or with another version (e.g., tarball downloaded from
> hostap.epitest.fi)?
>> I can provide any useful information, including packet dumps, but at
>> this point, I'm really not quite sure what direction to go.
> You could send a packet dump showing the end of EAP authentication and
> following corrupted frames. I'm not very familiar with FreeBSD  
> drivers,
> so I may not be able to help with this, though. If you do not get
> useful replies from other people on this issue, I would recommend  
> trying
> to find a more FreeBSD specific mailing list for getting more  
> details on
> what could be causing such behavior with dynamic WEP keying.
> -- 
> Jouni Malinen                                            PGP id  
> EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap

More information about the Hostap mailing list