wpa_supplicant troubles with connection following authentication (cannot get IP)

Jouni Malinen jkmaline
Fri Oct 14 22:42:20 PDT 2005

On Sat, Oct 15, 2005 at 12:15:48AM -0500, Joseph Love wrote:

> I am using FreeBSD 6.0RC1, with wpa_supplicant 0.4.5 (downloaded from  
> the hostap website).  The last time I tried 0.3.9, I received similar  
> results, and figured that maybe I should try a more recent version.   
> The version I tried on windows was also 0.4.5, but was the binary  
> version.
> A packet dump is available at http://www.getsomewhere.net/ 
> uicwireless.dump .  It seems that those LLC packets were for a  
> spanning tree protocol.
> I find the key config stuff you mentioned interesting.  I wonder if  
> there are issues with dynamic wep keying that I am facing.

This AP is using somewhat non-standard key configuration (something that
most Cisco APs do with IEEE 802.1X), i.e., unicast key is using non-zero
key index (2 or 3) and broadcast key is using the other indexes
(alternating between 0 and 1).

The packet dump looked like WEP decryption would not have been done or
it would have failed completely. I would assume that the driver code
would drop the packet if ICV is incorrect, so I would assume that the
packet was not decrypted at all.

I have seen this kind of key index use having issues with number of
drivers. In other words, this is a question for FreeBSD mailing lists
after all. Including the description of key index use with the message
should make it easier for the driver/IEEE 802.11 stack authors to take a
closer look at this. Anyway, a fix for this may require changing the
driver interface code for the set_key handler on wpa_supplicant side,

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list