[PATCH 1/3] fixup! Rename device_d::device_node to device_d::of_node
Sascha Hauer
sha at pengutronix.de
Tue Jan 10 06:44:02 PST 2023
On Mon, Jan 09, 2023 at 12:09:19PM +0100, Ahmad Fatoum wrote:
> - Out-of-tree patches often add a board driver, which may use the
> old device_d/driver_d naming. Especially with bisecting, this can
> be a hassle
>
> - We may split up some parts of struct device into a new
> struct platform_device like Linux does and we don't want
> to break out of tree patches twice.
>
> Thus add the old names as aliases for now.
>
> Signed-off-by: Ahmad Fatoum <a.fatoum at pengutronix.de>
> ---
> include/driver.h | 5 ++++-
> 1 file changed, 4 insertions(+), 1 deletion(-)
Applied, thanks
Sascha
>
> diff --git a/include/driver.h b/include/driver.h
> index 693d5cb3e580..c789f3151e70 100644
> --- a/include/driver.h
> +++ b/include/driver.h
> @@ -74,7 +74,10 @@ struct device {
> struct list_head cdevs;
>
> const struct platform_device_id *id_entry;
> - struct device_node *of_node;
> + union {
> + struct device_node *device_node;
> + struct device_node *of_node;
> + };
>
> const struct of_device_id *of_id_entry;
>
> --
> 2.30.2
>
>
>
--
Pengutronix e.K. | |
Steuerwalder Str. 21 | http://www.pengutronix.de/ |
31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |
More information about the barebox
mailing list