[PATCH 1/3] fixup! Rename device_d::device_node to device_d::of_node
Ahmad Fatoum
a.fatoum at pengutronix.de
Mon Jan 9 03:09:19 PST 2023
- Out-of-tree patches often add a board driver, which may use the
old device_d/driver_d naming. Especially with bisecting, this can
be a hassle
- We may split up some parts of struct device into a new
struct platform_device like Linux does and we don't want
to break out of tree patches twice.
Thus add the old names as aliases for now.
Signed-off-by: Ahmad Fatoum <a.fatoum at pengutronix.de>
---
include/driver.h | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/include/driver.h b/include/driver.h
index 693d5cb3e580..c789f3151e70 100644
--- a/include/driver.h
+++ b/include/driver.h
@@ -74,7 +74,10 @@ struct device {
struct list_head cdevs;
const struct platform_device_id *id_entry;
- struct device_node *of_node;
+ union {
+ struct device_node *device_node;
+ struct device_node *of_node;
+ };
const struct of_device_id *of_id_entry;
--
2.30.2
More information about the barebox
mailing list