barebox 2017.05 freezes on VirtualBox x86 boot with "BAREBOX JMP"

Sascha Hauer s.hauer at
Mon May 8 22:52:32 PDT 2017

Hi Josh,

On Mon, May 08, 2017 at 04:49:05AM -0400, Josh Beavers wrote:
> Greetings,
> I am trying to boot barebox on x86.  I have tried barebox 2016.06.0
> and 2017.05, both of which produce the same result.  I see the same
> thing as this thread from 2016, except the message has now been
> upgraded to "BAREBOX JMP":
> As far as I can tell by adding a pr_err() call, start_barebox() from
> common/startup.c does not get called at all.  Instead, something is
> locking up the system between the jump out of boot_hdisk.S and the
> startup code.  I am using VirtualBox as a generic 64-bit x86 system in
> case that matters.
> Any suggestions about what to investigate would be appreciated.

The barebox x86 port was probably only compile tested the last five
years, so I am not wondering at all. The EFI port should work fine and
is tested, but plain old x86 never reached a level in barebox that could
be called mature or usable.


Pengutronix e.K.                           |                             |
Industrial Linux Solutions                 |  |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |

More information about the barebox mailing list