reconnect script

Matthew Kitchin (public/usenet) mkitchin.public at
Fri May 27 16:25:47 EDT 2011

Openconnect version: OpenConnect version v2.25-unknown (That is what it 
Openwrt Backfire

I'm currently running the very low tech reconnect script below.

ping -c 4 2>/dev/null 1>/dev/nul
       if [ $? -ne 0 ]; then
          killall openconnect
          echo passwd|openconnect https://myIP --no-cert-check --script 
/etc/vpn-script --user=username --passwd-on-stdin

It runs every minute. I know it is not the ideal way to do it. I tried 
to get it working in a cleaner way with an init script, but I never 
could get it to reconnect properly.
After about 3 days, I lose all connectivity between the devices on my 
192.168.1.x subnet. The devices can still get to the internet, still get 
to the remote vpn subnets, but cannot see each other. Killing the 
openconnect process fixes this. Rebooting the router fixes everything.
Again, I completely admit this is not the best way to do this. Before I 
deal with trying to change it, I wanted to see if you thought that would 
cause the problem I'm experiencing. Would you suspect this was some sort 
of openwrt issue instead?


More information about the openconnect-devel mailing list