reconnect script

David Woodhouse dwmw2 at
Fri May 27 17:27:42 EDT 2011

On Fri, 2011-05-27 at 15:25 -0500, Matthew Kitchin (public/usenet)
> Openconnect version: OpenConnect version v2.25-unknown (That is what it 
> reports)

That'll be because it's patched so it's not a "clean" v2.25. You ought
to upgrade to v3.02.

> After about 3 days, I lose all connectivity between the devices on my 
> 192.168.1.x subnet. The devices can still get to the internet, still get 
> to the remote vpn subnets, but cannot see each other.

How are the machines connected to one another? And if they can still
happily see everything but each other, wtf is your 'ping'

What does your routing table look like before you kill the offending
openconnect process, what does it look like when openconnect is dead,
and what does it look like when you've run a new openconnect process and
everything is working again?

>  Killing the openconnect process fixes this. Rebooting the router
> fixes everything.

Where does the router fit in the network? Can you describe your network
topology? I'm completely lost.

Do you have 'openconnect -v' output from the time when this goes wrong?
I assume it thinks it's still working correctly, given that traffic
*over* it is still working OK?


More information about the openconnect-devel mailing list