*** DANGER *** unable to remove socket power - reservee= doesn't help

Elmar Athmer linux at nixus-minimax.de
Sun Jan 30 07:26:18 EST 2005

Hi, still doesn't work.

OK, here's what I did...

installed Kernel 2.6.11-rc2, passed override_bios=1 to yenta_socket.
Still error:
"PCMCIA: socket df09202c: *** DANGER *** unable to remove socket power"

Then I passed reserve=0xd0209000,0x5000 to the 2.6.11-rc2 Kernel, still
the same error.

One time I got "cs: pcmcia_socket0: unable to apply power", so I did as
described on the website
# setpci -s 06.0 0x80.l
Didn't know what to set now...
setpci -s 06.0 0x80.l=0x08443060 or setpci -s 06.0 0x80.l=0x0818443060,
but without any success, still the unable to remove socket power error.

Another thing I noticed: If id do cardctl info, it reports "no pcmcia
driver in /proc/devices", with Kernel 2.6.8 I got empty fields.

Oh, did I mention: The Power LED on the Orinoco-Card blinks about every
5 seconds...

OK, what to do now?


More information about the linux-pcmcia mailing list