[tslib] Issue with tslib / QtQuick on yocto embedded linux

Sebastian Gonzalez s.gonzalez at riele.de
Thu Mar 15 00:04:51 PDT 2018


I'm working on a project using yocto on an single board computer with a 
resistive touchscreen and I'm experiencing some trouble at the 
interaction between tslib and Qt.

Touchscreen is working fine, so I can run ts_calibrate, ts_test, 
ts_print without problems.

However, I noticed that when running a QtQuick-Application sometimes 
touch events are not being recognized. While running ts_print 
simultaneously with the Qt-App I've noticed that sometimes when I 
release the touchscreen ts_print is outputting a negative value for the 
x coordinate e. g.:

1519911645.587488:     -23    128    0

normally, the output releasing the touchscreen at this point it would 
look like that:

1519911642.989189:     491    47    0

When this negative value is being output, my App doesn't recognize the 
touch event. I've attached a picture of the console output. There you 
can see this situation, after the -23 there is no output from Qt-App 
(pressing a button would output: qml: Button Pressed. Entered Text: 

Is there a form to prevent tslib outputting these negative values? I 
tried to use module skip, median, lowpass or iir in /etc/ts.conf but 
they are not present at the target. The contents of /usr/lib/ts/ are:

drwxr-xr-x root       root             4096 ./usr/lib/ts
-rwxr-xr-x root       root             5516 ./usr/lib/ts/dejitter.so
-rwxr-xr-x root       root             5536 ./usr/lib/ts/dmc.so
-rwxr-xr-x root       root             9636 ./usr/lib/ts/galax.so
-rwxr-xr-x root       root             9632 ./usr/lib/ts/input.so
-rwxr-xr-x root       root             5460 ./usr/lib/ts/linear_h2200.so
-rwxr-xr-x root       root             9636 ./usr/lib/ts/linear.so
-rwxr-xr-x root       root             5520 ./usr/lib/ts/pthres.so
-rwxr-xr-x root       root             5460 ./usr/lib/ts/tatung.so
-rwxr-xr-x root       root             5468 ./usr/lib/ts/touchkit.so
-rwxr-xr-x root       root             5516 ./usr/lib/ts/variance.so

How can the modules skip, median, lowpass, iir be added to the target in 
yocto? I tried passing --enable-skip to configure but it didn't 
recognize this option. Which are valid options?

I would appreciate any help.


Best regards

Sebastian Gonzalez


Kurfuerstenstr. 75-79, 13467 Berlin
Tel. +49-30-4000 97 10
Fax +49-30-404 05 29
S.Gonzalez at riele.de <mailto:S.Gonzalez at riele.de>
www.riele.de <http://www.riele.de/>

-------------- next part --------------
A non-text attachment was scrubbed...
Name: Bildschirmfoto vom 2018-03-14 13-40-51.png
Type: image/png
Size: 79109 bytes
Desc: not available
URL: <http://lists.infradead.org/pipermail/tslib/attachments/20180315/f8a407ce/attachment.png>

More information about the tslib mailing list