[tslib] Issue with tslib / QtQuick on yocto embedded linux

Martin Kepplinger martink at posteo.de
Thu Mar 15 00:31:01 PDT 2018

Am 15.03.2018 08:04 schrieb Sebastian Gonzalez:
> Hello,
> I'm working on a project using yocto on an single board computer with
> a resistive touchscreen and I'm experiencing some trouble at the
> interaction between tslib and Qt.
> Touchscreen is working fine, so I can run ts_calibrate, ts_test,
> ts_print without problems.
> However, I noticed that when running a QtQuick-Application sometimes
> touch events are not being recognized. While running ts_print
> simultaneously with the Qt-App I've noticed that sometimes when I
> release the touchscreen ts_print is outputting a negative value for
> the x coordinate e. g.:
> 1519911645.587488:     -23    128    0
> normally, the output releasing the touchscreen at this point it would
> look like that:
> 1519911642.989189:     491    47    0
> When this negative value is being output, my App doesn't recognize the
> touch event. I've attached a picture of the console output. There you
> can see this situation, after the -23 there is no output from Qt-App
> (pressing a button would output: qml: Button Pressed. Entered Text:
> Test-Text)
> Is there a form to prevent tslib outputting these negative values? I
> tried to use module skip, median, lowpass or iir in /etc/ts.conf but
> they are not present at the target. The contents of /usr/lib/ts/ are:
> drwxr-xr-x root       root             4096 ./usr/lib/ts
> -rwxr-xr-x root       root             5516 ./usr/lib/ts/dejitter.so
> -rwxr-xr-x root       root             5536 ./usr/lib/ts/dmc.so
> -rwxr-xr-x root       root             9636 ./usr/lib/ts/galax.so
> -rwxr-xr-x root       root             9632 ./usr/lib/ts/input.so
> -rwxr-xr-x root       root             5460 
> ./usr/lib/ts/linear_h2200.so
> -rwxr-xr-x root       root             9636 ./usr/lib/ts/linear.so
> -rwxr-xr-x root       root             5520 ./usr/lib/ts/pthres.so
> -rwxr-xr-x root       root             5460 ./usr/lib/ts/tatung.so
> -rwxr-xr-x root       root             5468 ./usr/lib/ts/touchkit.so
> -rwxr-xr-x root       root             5516 ./usr/lib/ts/variance.so
> How can the modules skip, median, lowpass, iir be added to the target
> in yocto? I tried passing --enable-skip to configure but it didn't
> recognize this option. Which are valid options?
> I would appreciate any help.

First, what version of tslib are you using? It looks like it's not 1.15;
Can you do try that and see if you have the samke problems?

skip, median, lowpass and iir are all filters that were added after 1.3 
or so;
see the release page https://github.com/kergoth/tslib/releases/ or the
NEWS file.

If you have these or any problems with 1.15 I'm happy to help you
from there :)



More information about the tslib mailing list