diskonchip2000 support in 2.4.22

Jonathan M. Schlueter jonschl at umd.umich.edu
Sun May 9 15:41:05 EDT 2004

On Sun, 9 May 2004, Andre Sodermans wrote:

> hello all,
> I can't access my diskonchip2000 partitions from
> linux. I have linuxmz 2.4.18 installed on it and it
> boots fine from diskonchip.
> The kernel I built for LFS5.0 is based on 2.4.22.
> I compiled the kernel with:
> Running modprobe docprobe, I get:
> DiskOnChip Millennium found at address: 0xD000
> no flash chips recognized
> It is actually a diskonchip2000.
> There is no entry in /proc/mtd.

Which driver are you using?

> After I installed the kernel I noticed that I was
> missing the /dev/msys/fla* so I created those. Also
> the /dev/nftl* were missing, so I downloaded the
> latest mtd snapshot and ran the MAKEDEV script.

/dev/msys/fla* are the dev files from M-Sys's custom driver

/dev/nftla  are the dev files for the mtd subsystem (this list)

They are two seperate and different methods of accessing the DiskonChip

> I tried to mount -t ext2 /dev/msys/fla1 /mnt/doc -
> result:
> mount: /dev/msys/fla1 is not a valid block device
> I tried to mount -t ext2 /dev/nftla
> mount: /dev/nftla1: unknown device
> Did I miss something?

Jon Schlueter

More information about the linux-mtd mailing list