DiskOnChip 2000 with Mandrake Linux with kernel 2.4.18

Hor Meng Yoong yhm at pacific.net.sg
Wed Sep 18 17:44:20 EDT 2002


  I need your advice on using DiskOnChip 2000 using Linux with kernel
version 2.4.18.

Currently, I have installed Linux with MTD compiled.  My distribution is
Mandrake 8.1
I used grub to boot the system. I encountered the following symptoms:

a)  The DOC firmware was DOC42.fff (dummy firmware)
     - I tried to boot normal kernel, the system kept on resetting
     - I tried to boot the kernel with failsafe mode, it is okay. But I
could not see the DOC using dmesg command.

b)  The DOC firmware was DOC42.EXB
      - I tried to boot normal or failsafe mode, in both cases, grub
told me:
           "kernel (hd0,0)/boot/vmlinuz root=/dev/hda1 devfs=mount
failsafe mem=128M
                 [Linux-bzImage,  setup=0x1400,  size=0xfe6c8]
                 Error 28: Selected item cannot fit into memory".

Could you reply directly to me as I could not subscribe to the mailing
list as the mxverify script could not
connect to my mail server.

Yoong Hor Meng

More information about the linux-mtd mailing list