[boot-wrapper PATCH 10/12] aarch32: rename `_spin_dead` -> `err_invalid_id`

Mark Rutland mark.rutland at arm.com
Thu Jul 29 08:20:48 PDT 2021


For clarity, align aarch32 with aarch64, sending unexpected CPUs to an
`err_invalid_id` loop rather than `_spin_dead`.

There should be no functional change as a result of this patch.

Signed-off-by: Mark Rutland <mark.rutland at arm.com>
---
 arch/aarch32/boot.S | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/aarch32/boot.S b/arch/aarch32/boot.S
index 15e51d4..9e5c308 100644
--- a/arch/aarch32/boot.S
+++ b/arch/aarch32/boot.S
@@ -21,7 +21,7 @@ ASM_FUNC(_start)
 	cpuid	r0, r1
 	bl	find_logical_id
 	cmp	r0, #MPIDR_INVALID
-	beq	_spin_dead
+	beq	err_invalid_id
 
 	bl	setup_stack
 
@@ -58,7 +58,7 @@ _monitor:
 	/* Initialise boot method */
 	b	start_el3
 
-_spin_dead:
+err_invalid_id:
 	b	.
 
 	.text
-- 
2.11.0




More information about the linux-arm-kernel mailing list