[boot-wrapper PATCH 10/12] aarch32: rename `_spin_dead` -> `err_invalid_id`

Andre Przywara andre.przywara at arm.com
Fri Jul 30 10:39:19 PDT 2021


On Thu, 29 Jul 2021 16:20:48 +0100
Mark Rutland <mark.rutland at arm.com> wrote:

> For clarity, align aarch32 with aarch64, sending unexpected CPUs to an
> `err_invalid_id` loop rather than `_spin_dead`.
> 
> There should be no functional change as a result of this patch.
> 
> Signed-off-by: Mark Rutland <mark.rutland at arm.com>

Reviewed-by: Andre Przywara <andre.przywara at arm.com>

Cheers,
Andre

> ---
>  arch/aarch32/boot.S | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/arch/aarch32/boot.S b/arch/aarch32/boot.S
> index 15e51d4..9e5c308 100644
> --- a/arch/aarch32/boot.S
> +++ b/arch/aarch32/boot.S
> @@ -21,7 +21,7 @@ ASM_FUNC(_start)
>  	cpuid	r0, r1
>  	bl	find_logical_id
>  	cmp	r0, #MPIDR_INVALID
> -	beq	_spin_dead
> +	beq	err_invalid_id
>  
>  	bl	setup_stack
>  
> @@ -58,7 +58,7 @@ _monitor:
>  	/* Initialise boot method */
>  	b	start_el3
>  
> -_spin_dead:
> +err_invalid_id:
>  	b	.
>  
>  	.text




More information about the linux-arm-kernel mailing list