[PATCH 2/9] locking/qrwlock: avoid redundant atomic_add_return on read_lock_slowpath
Will Deacon
will.deacon at arm.com
Wed Jul 8 06:37:04 PDT 2015
On Wed, Jul 08, 2015 at 10:59:44AM +0100, Peter Zijlstra wrote:
> On Tue, Jul 07, 2015 at 03:28:13PM -0400, Waiman Long wrote:
> > #ifndef queued_inc_reader_return
> > static inline u32 queued_inc_reader_return(struct qrwlock *lock)
>
> That's actually a misleading name, we don't do an inc_return, we do a
> fetch_inc.
>
> > {
> > return atomic_add_return(_QR_BIAS, &lock->cnts) - _QR_BIAS;
> > }
> > #endif
>
> With that you (Will) could even reuse the ll/sc load and avoid issuing a
> second load. You basically need atomic_fetch_add_relaxed().
ARMv8.1 has an instruction for that :) [ldadd].
Will
More information about the linux-arm-kernel
mailing list