[PATCH 2/9] locking/qrwlock: avoid redundant atomic_add_return on read_lock_slowpath

Peter Zijlstra peterz at infradead.org
Wed Jul 8 02:59:44 PDT 2015


On Tue, Jul 07, 2015 at 03:28:13PM -0400, Waiman Long wrote:
> #ifndef queued_inc_reader_return
> static inline u32 queued_inc_reader_return(struct qrwlock *lock)

That's actually a misleading name, we don't do an inc_return, we do a
fetch_inc.

> {
>     return atomic_add_return(_QR_BIAS, &lock->cnts) - _QR_BIAS;
> }
> #endif

With that you (Will) could even reuse the ll/sc load and avoid issuing a
second load. You basically need atomic_fetch_add_relaxed().



More information about the linux-arm-kernel mailing list