[PATCH] omap2+: mux: Add macro for configuring static with omap_hwmod_mux_init (Re: [PATCH] omap2+: mux: Remove the use of IDLE flag)

Sricharan R r.sricharan at ti.com
Wed Mar 9 23:26:20 EST 2011


Tony,
>-----Original Message-----
>From: Tony Lindgren [mailto:tony at atomide.com]
>Sent: Thursday, March 10, 2011 2:02 AM
>To: Sricharan R
>Cc: linux-omap at vger.kernel.org; Benoit Cousson; Santosh Shilimkar;
>paul at pswan.com; linux-arm-kernel at lists.infradead.org
>Subject: [PATCH] omap2+: mux: Add macro for configuring static with
>omap_hwmod_mux_init (Re: [PATCH] omap2+: mux: Remove the use of IDLE
flag)
>
>* Sricharan R <r.sricharan at ti.com> [110309 03:47]:
>>
>> Btw,I have fixed the comments on the below patches that
>> I sent for configuring the serial pads.
>>
>> 4430sdp:
>> http://marc.info/?l=linux-omap&m=129900334420003&w=2
>>
>> omap4panda:
>> http://marc.info/?l=linux-omap&m=129900338520082&w=2
>>
>> 3430sdp:
>> http://marc.info/?l=linux-omap&m=129619117726479&w=2
>>
>> Can you please check if they are ok?
>
>Look OK to me, but let's make things a bit easier to read
>and maintain with the following patch. Can you please
>update your patches to use this macro?
>
>Each line then just becomes something like:
>
>OMAP_MUX_STATIC("uart3_tx_irtx.uart3_tx_irtx",
>		OMAP_PIN_OUTPUT | OMAP_MUX_MODE0),
>
Ok thanks. I will update and send again.
>Regards,
>
>Tony
>
>
>From: Tony Lindgren <tony at atomide.com>
>Date: Wed, 9 Mar 2011 12:14:04 -0800
>Subject: [PATCH] omap2+: mux: Add macro for configuring static with
>omap_hwmod_mux_init
>
>Add macro for defining static pins in the board file.
>
>We can now start implementing pin multiplexing in the platform init
>code for devices that call omap_hwmod_mux_init. Currently that is
>only implemented for serial.c.
>
>Signed-off-by: Tony Lindgren <tony at atomide.com>
>
>--- a/arch/arm/mach-omap2/mux.h
>+++ b/arch/arm/mach-omap2/mux.h
>@@ -186,6 +186,12 @@ struct omap_device_pad {
>
> struct omap_hwmod_mux_info;
>
>+#define OMAP_MUX_STATIC(signal, mode)					\
>+{									\
>+	.name	= (signal),						\
>+	.enable	= (mode),						\
>+}
>+
> #if defined(CONFIG_OMAP_MUX)
>
> /**



More information about the linux-arm-kernel mailing list