[PATCH v9 3/3] PCI: dwc: Remove redundant MPS configuration

sashiko-bot at kernel.org sashiko-bot at kernel.org
Wed Sep 16 08:44:46 PDT 2026


> The Meson PCIe controller driver manually configures maximum payload
> size (MPS) through meson_set_max_payload, duplicating functionality now
> centralized in the PCI core.  Deprecating redundant code simplifies the
> driver and aligns it with the consolidated MPS management strategy,
> improving long-term maintainability.
> 
> With meson_set_max_payload() gone, meson_size_to_payload() is only used
> for MRRS.  Rename it to meson_size_to_mrrs(), update the warning message,
> and drop the now-unused PCIE_CAP_MAX_PAYLOAD_SIZE and MAX_PAYLOAD_SIZE
> macros.
> 
> Reviewed-by: Manivannan Sadhasivam <mani at kernel.org>
> Signed-off-by: Hans Zhang <18255117159 at 163.com>

Sashiko has reviewed this patch and found no issues. It looks great!

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260916153907.60344-1-18255117159@163.com?part=3




More information about the linux-amlogic mailing list