Problems writing ELF dumps with makedumpfile 1.2.9

Worth, Kevin kevin.worth at
Wed Oct 1 15:12:59 EDT 2008

Using rc2 patch:

Copying data                       : [100 %]

The dumpfile is saved to /root/var/crash/vmcore.

makedumpfile Completed.

Aha! That worked!

I'm suspecting the Ubuntu dev that changed the compile flags may not have realized what implications it could have.

Additionally, we did resolve+test the problem with using -d values >1, so that is an improvement, as well. Thank you very much for your help in this, Ken'ichi! I'll be submitting 1.3.0 to the Ubuntu devs as soon as the final version is released :)

Now on to the next issue... I get a " cannot access vmalloc'd module memory" when I load my dump files in crash :\  Behavior is the same with using cp instead of makedumpfile, so appears to be a crash or kdump issue. Will send a separate email to the list on that topic.

Thanks again.


-----Original Message-----
From: Ken'ichi Ohmichi [mailto:oomichi at]
Sent: Tuesday, September 30, 2008 10:07 PM
To: Worth, Kevin
Cc: Masaki Tachibana; kexec-ml
Subject: Re: Problems writing ELF dumps with makedumpfile 1.2.9

Hi Kevin,

Ken'ichi Ohmichi wrote:
>> I've attached the log files from running strace.
>> Hopefully they contain some clue as to where this failure is occurring.
>> I tried specifying -d30 and it still failed. Both traces attached.
> Thank you for some log files.
> vmcore-d30.log:
>   open("/proc/vmcore", O_RDONLY)          = 4
>   [snip]
>   lseek(4, 2885288664, SEEK_SET)          = -1 EINVAL (Invalid argument)
> Your system has 4GB memory, and /proc/vmcore size is almost 4GB, right ?
> If yes, the above lseek() should *not* fail because the offset (almost 2.7GB)
> is in /proc/vmcore. So I guess that this problem is due to a kernel.

I should see the log more carefully.

According to your log, lseek(2) is called even if makedumpfile is
compiled by -D_FILE_OFFSET_BITS=64. On my system (RHEL5), _llseek()
is called instead of it. This difference is due to each environment.

To fix it, I added both -D_LARGEFILE_SOURCE and -D_LARGEFILE64_SOURCE
with -D_FILE_OFFSET_BITS=64 and I uploaded makedumpfile-1.3.0-rc02.tar.gz
to the following:

I guess/hope that this makedumpfile fixes your problem.
Please try it on your system.

Ken'ichi Ohmichi

More information about the kexec mailing list