Hostapd Multicast Group Key Issue on PowerPC vs x86

Jouni Malinen j
Wed May 6 06:00:54 PDT 2009

On Tue, May 05, 2009 at 06:29:01PM +0100, Damon Southworth wrote:

> Thanks, that solved the problem with all the devices (Atheros, Prism54
> and broadcom) I had tried using the nl80211 interface.
> This now confirms that the Multicast group key issue only exists when
> using the Madwifi driver interface.

Thanks for the additional information and testing. My guess would be
that the current sequence number fetching for the group key would end up
using incorrect byteorder in your big endian PowerPC build for some
reason. Could you please take a look at the madwifi_get_seqnum()
function and verify that WORDS_BIGENDIAN is defined there to swap the
byte order? If that is the case and the end result does not work, you
could try testing the not-WORDS_BIGENDIAN version that does not swap the
TSC octets.

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list