Hostapd Multicast Group Key Issue on PowerPC vs x86

Damon Southworth damon
Mon May 11 10:22:09 PDT 2009

Jouni Malinen wrote:
> On Tue, May 05, 2009 at 06:29:01PM +0100, Damon Southworth wrote:
>> Thanks, that solved the problem with all the devices (Atheros, Prism54
>> and broadcom) I had tried using the nl80211 interface.
>> This now confirms that the Multicast group key issue only exists when
>> using the Madwifi driver interface.
> Thanks for the additional information and testing. My guess would be
> that the current sequence number fetching for the group key would end up
> using incorrect byteorder in your big endian PowerPC build for some
> reason. Could you please take a look at the madwifi_get_seqnum()
> function and verify that WORDS_BIGENDIAN is defined there to swap the
> byte order? If that is the case and the end result does not work, you
> could try testing the not-WORDS_BIGENDIAN version that does not swap the
> TSC octets.
Sorry for the slight delay in trying this...
The WORDS_BIGENDIAN compilation switch is defined in the driver and I
have tried sending the the code through both options of swapping and not
swapping the bytes but it does not make any difference to the operation.
  I have also checked that the size of the copied value is 8 bytes as
the byte swap code uses "sizeof(wk.ik_keytsc)" and "WPA_KEY_RSC_LEN"
interchangeably but they do evaluate to the same.

Broadcasts and Multicasts still only come through after the first rekey.
I have also tried a small modification to the code to allow an initial
GTK to be rekeyed at a different interval. This is defaulted to be one
second so a re-key takes place imediately at startup followed by
subsquent re-keys at the normal interval. This fixes the problem even
though the re-key is before any stations have connected and exchanged
keys which is when the madwifi_get_seqnum() would be called. Does this
help to narrow down where the problem could be?

More information about the Hostap mailing list