[FYI] hostapd state with mac80211 on linux

Guillaume Chevillot guillaume
Mon Oct 29 05:55:41 PDT 2007

> hostapd works with
>  - kernel 2.6.24-rc1
>  - plus my patches from http://johannes.sipsolutions.net/patches/kernel/all/
>  - plus the commit 5c58298c2536252ab95aa2b1497ab47eb878ca5d from net-2.6
>    ([NETLINK]: Fix ACK processing after netlink_dump_start)
>  - my hostapd patches from http://johannes.sipsolutions.net/patches/hostap/all/
I tried with a kernel downloaded from git (so with the netlink commit
already merge into) without success.

Some code of the old interface has been removed so I had to apply some
of your patches manually and tried to reinsert the removed code to be able
to compile. I did this quickly so I suppose I forgot to re-add some

After compiling kernel and hostapd, hostapd complains the same that
before with this error message more :
rmdir[ctrl_interface]: No such file or directory

And stops here.

So I think, you will have to do one more patch for the rc2, ...

Tell me if I am wrong, but your patches "just" keep the old interface,
master mode code and others previously removed. So, new code will have
to be done to re-enable master mode and a driver_mac80211.c (rather than
a driver_deviscape.c) will have to be done for hostapd ?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20071029/977716c1/attachment.pgp 

More information about the Hostap mailing list