MIC failure after 4 way handshake (after PTK is installed and beforeGTK is received)

Bar, Eitan eitanb
Thu Oct 6 01:46:19 PDT 2005

Hi All,

I just wanted to say (to whoever is interested) that I have managed to SOLVE this issue by SWITCHING the TX and RX MIC set along with the PTK.

No more MIC failures :)


-----Original Message-----
From: hostap-bounces+eitanb=ti.com at shmoo.com [mailto:hostap-bounces+eitanb=ti.com at shmoo.com] On Behalf Of Bar, Eitan
Sent: Thursday, October 06, 2005 9:14 AM
To: hostap at shmoo.com
Subject: MIC failure after 4 way handshake (after PTK is installed and beforeGTK is received)

I?ve tried both wpa_upplicant 0.3.9 and 0.4.4, but the problem remains the same ? I receive MIC failures from the driver right after the PTK is set and the AP transmits the GTK (encrypted)
A zipped sniffer (Airopeek) capture file is included, and also below is a dump taken from wpa_supplicant (0.4.4 in this case).
NOTE: please IGNORE the debug messages about the invalid scan results, this is a different story. In anyways - I?m providing the AP RSN/WPA IE through EVENT_ASSOCINFO event).
I did verify that the key is relayed to the driver as it should (16 bytes key, 8 bytes RX MIC, 8 bytes TX MIC).

(Also, a small note: this driver has already been verified to work with another supplicant, so I assume the MIC check in driver/firmware is valid).
I would really appreciate any help or suggestions as to what can be wrong.
If anybody else has encountered this situation before I would like to hear what solved it...

Could this be a big/little endian issue? I really have no clue?

p.s: wpa_supplicant log is also attached as zip file (sorry, msg was too big to send)...

More information about the Hostap mailing list