Upgrade to new kernel stops wpa

Mårten Thomasson marten.thomasson
Wed Oct 5 13:45:31 PDT 2005

Well, to be honest, how do I apply this patch? I tried to apply it with
"patch ./broadcast.patch" but no can do? Could you be more specific about
how to apply it? Is it the ieee80211 that needs the patch?



-----Original Message-----
From: hostap-bounces+marten.thomasson=bredband.net at shmoo.com
[mailto:hostap-bounces+marten.thomasson=bredband.net at shmoo.com] On Behalf Of
Dimitris Kogias
Sent: 05 October 2005 21:23
To: hostap at shmoo.com
Subject: Re: Upgrade to new kernel stops wpa

M?rten Thomasson wrote:
> Well, yes I did, and then the encryption seems to work (I.e. no error
> messages) but for some reason I cannot get an IP from the dhcpserver... 

Have you tried the patch mentioned here:


It did the trick for me:  Debian sid, kernel from kernel.org,
ipw2200-1.0.6, ieee80211-1.0.3, wpa-supplicant 0.4.4-1 from Debian sid,
WPA-PSK, hardware crypto enabled on the 2200.

HostAP mailing list
HostAP at shmoo.com

More information about the Hostap mailing list