hostapd groupkey problem with madwifi

Mailinglists mailinglists
Fri Jan 14 09:44:00 PST 2005

Thanks for this advice.. I just tried it and it works flawless now when
using TKIP only.

Hardware: LevelOne WNC-0300 as master and ndiswrapper as client

Am Freitag, den 14.01.2005, 13:44 +0100 schrieb Sebastian Weitzel:
> Hi,
> I'm not sure if I should better ask this on the madwifi mailinglist, but
> since my problem occured through a change in hostap cvs I decided so.
> I was using hostapd successfully with madwifi till version 0.2.4 of
> hostap. I tried a fresh cvs checkout this year and it did not worked
> anymore.
> The connection is configured as WPA-PSK. Authentication process is not
> going further 1/4 of 4-way handshake.
> I tracked down the problem to a change in driver_madwifi.c, done on
> 18.12.2004, revision 1.6 of this file. If I remove the line "wk.ik_flags
> |= IEEE80211_KEY_DEFAULT;" it works again. By the way, hostapd prints outs
> eap timeout during authentication.
> The system I tested this issue on is a xscale ixp425 system, I dont know
> if the problem has anything to do with this.
> Regards,
> Sebastian Weitzel
> _______________________________________________
> HostAP mailing list
> HostAP at

++++++++++++ WERBUNG +++++++++++++++
52 MB Postfach / Spam- und Virenfilter

ISP / Qualit?ts-Webhosting

More information about the Hostap mailing list