Andrea G. Forte andreaf
Wed Feb 18 13:09:58 PST 2004

I did not include other messages than the one with unsupported ioctl
because that is the only error message I get. All the rest seems to work
I tried to add entries in /etc/pcmcia/config but once this was done, the
card was recognized as ethernet not as wireless lan. This would make the
Zaurus freeze when starting the tcp/ip service (the only service allowed
since the card was recognized as ethernet).
I tried to rename the hostap.conf in zhostap.conf as you said but nothing
would happen. Can the class of the device be changed from "network" to
"wlan-ng"? Doing so the card gets recognized as wireless and not as
ethernet, but it gives me the unsupported ioctl I told you about before.

Thank you for all of your help.

On Wed, 18 Feb 2004, Pavel Roskin wrote:

> On Wed, 18 Feb 2004, Andrea G. Forte wrote:
> > We modified the original wlan-ng file to load the hostap modules instead
> > of the prism2 modules for our card. We tried to use the hostap config file
> > as Pavel said, but when inserting the card it would not be recognized as
> > "inserted" and therefore no drivers would be loaded.
> I'm sorry, but the only way to make hostap work is to have it loaded by
> cardmgr.  This means that the appropriate entry for the card should be in
> /etc/pcmcia/config or in a file included from it.  When wlan-ng is
> executed, it's too late.
> I believe your interpretation of the problem is incorrect, but you didn't
> provide any exact messages, so I cannot help you.  The problem has nothing
> to do with either driver, by the way.  It's a problem with cardmgr and its
> configuration files.
> --
> Regards,
> Pavel Roskin

More information about the Hostap mailing list