HostAP 0.0.4 depmod -ae and Makefile

Jason Boxman jasonb
Mon Sep 22 17:25:24 PDT 2003


When compiling the latest HostAP against my 2.4.22-ac1 kernel, I encountered 
the following issues.

I ran a `make` and all was well.  When I ran `make install` it exploded 
because I didn't have an /etc/pcmcia directory.  It's a desktop system, so I 
don't need pcmcia installed.

(Actually, this is irrelevant since I just compiled latest CVS and it works 
fine.  The Makefile issue still exists, though.)

When I run `depmod -ae`, I have unresolved symbols.

sarah:/usr/src/hostap-0.0.4# depmod -ae
depmod: *** Unresolved symbols in /lib/modules/2.4.22-ac1/net/hostap.o
depmod:         hostap_get_crypto_ops
depmod: *** Unresolved symbols in 
depmod:         hostap_register_crypto_ops
depmod:         hostap_unregister_crypto_ops
depmod: *** Unresolved symbols in /lib/modules/2.4.22-ac1/pcmcia/hostap_cs.o
depmod:         register_pccard_driver_R1c442d6c
depmod:         CardServices_Re4eef0a4
depmod:         unregister_pccard_driver_Rdb348cd2

However, hostap_pci loads just fine.

sarah:/usr/src/hostap-0.0.4# uname -a
Linux sarah 2.4.22-ac1 #1 Mon Sep 1 02:22:19 EDT 2003 i586 GNU/Linux
sarah:/usr/src/hostap-0.0.4# modprobe hostap_pci
sarah:/usr/src/hostap-0.0.4# lsmod
Module                  Size  Used by    Not tainted
nfsd                   65680   8  (autoclean)
lockd                  46992   1  (autoclean) [nfsd]
sunrpc                 63648   1  (autoclean) [nfsd lockd]
hostap_pci             38300   0  (unused)
hostap                 86920   0  [hostap_pci]
rtc                     6408   0  (autoclean)
sd_mod                 10316   2  (autoclean)
xfs                   446364   1  (autoclean)
3w-xxxx                34144   1
scsi_mod               83760   2  [sd_mod 3w-xxxx]
natsemi                15104   1


Jason Boxman
Administrator TrekWeb.COM - Linux Pages

More information about the Hostap mailing list