clients don't associate to 0.1.0 --> AP: drop packet to non-associated STA

Jirka Bohac jbohac
Sat Oct 18 02:12:23 PDT 2003

Hello world,

yesterday I upgraded form a September-24's CVS version of hostap to
0.1.0. HostAP manages 3 cards (ZCOM XI626), two of them in master mode, one

I've seen strange problems with client's not associating correctly to
the AP:

After a while, a few windows-based clients associated, but none of the
many linux+hostap based clients (using a mixture of older hostap
versions). All clients' MAC addresses appeared in the ARP table,
although there was no message in syslog saying that the clients
associated. Also, their MAC could not be found in

However, since the kernel knew their MACs, it tried to send packets to
them, resulting in tons of messages like this in the syslog:

AP: drop packet to non-associated STA <client's MAC address>

And now the strangest thing:
I loaded the previous hostap modules, let the clients associate. Then I
put the MAC policy to closed, and kicked them all out. After that, when
I unloaded the old hostap modules and reloaded 0.1.0, the clients
associated to the AP. However, still not all of them (maybe because they
did not associate to the old version and were not kicked...)

I just can't find an explanation to this - how could kicking the clients
from the previous hostap version help them associate with the new one?
I tried several times, and this really seems to work.

I switched back to the old version of hostap, because my box routes a lot of
traffic and I don't want to cause trouble to people using it... not all
of them associated to the 0.1.0.

I don't use hostapd, My AP has a "deny" mac policy, listing just a few
denied MACs.

There have been other people in our community, reporting similar

Any help, suggestions, or rtfms greatly appreciated!

Jirka Bohac
CZFree.Net, Czechia

More information about the Hostap mailing list