Hostap driver in Managed mode fails to identify access points (i.e. hostap in Master mode) in range!

Martin Whitlock martin.whitlock
Wed Nov 13 06:01:41 PST 2002

> > The laptop running hostap in Managed mode failed to associate with the
> > access point( i.e. with the laptop where hostap was in Master mode.)
> >
> > I observed that the access point's mac address displayed by the station
> > (i.e. hostap in Managed mode)
> > was always 44:44:44:44:44:44, although the actual mac address
> of the hostap
> > access point was different.
> This (44:44:44:44:44:44) means it's looking for an AP with a
> matching essid to
> join with.
> Works fine here, I use hostap to connect to orinoco and lynksys
> AP's with wep
> and without every day.

I have also experienced this problem, but only when I have tried to connect
to HostAP-based access points. Might be a HostAP(AP)-to-HostAP(Client)
problem?? The strange thing is that it works sometimes, but VERY unreliable.
It usually works right after the device in Master mode is restarted, and
stops to work if the Client side is restarted afterwards.

I use the 2002-10-12 version on both sides. I have also tried to connect the
same clients to older versions of HostAP in Master mode, and this works


More information about the Hostap mailing list