TX53: Not Bootable from next tree

Christian Kapeller christian.kapeller at cmotion.eu
Mon Nov 5 08:27:26 EST 2012

>> I've just flashed barebox from the next tree onto a TX53-8030 module,
>> and have to report, that the board won't boot.
>> Currently I've tried to run it with MMU off and setting the text-base
>> to 0x71000000, with no positive results.
>> I'll do further investigation, but meanwhile does anyone have barebox
>> running on a TX53 board?
> I just tested that it works for me as second stage. I can't test 1st
> stage atm as I currently have no physical access to the board.

Until now I've used bb in a 2nd stage configuration on top of the supplied
Redboot, and it worked without any problem.

Additionally I had CONFIG_MACH_DO_LOW_LEVEL_INIT disabled which skips
another pll setup step, that was already done by Redboot.

> Some guesses: Have you checked the correct the correct board revision in
> the config? It's the default, so I assume it's correct.

Yes, I did check for the correct board revision, and am using the
correct one: CONFIG_TX53_REV_XX30=y

> Are you using the barebox-flash-image link or barebox.bin? You have to
> use the former because it's a compressed image.

I've noticed, that the link target changes depending on build
configuration. So I've flashed the file pointed to by barebox-flash-image.

> You might want to disable compressed image support in
>  General settings ->
>   memory layout ->
>    [ ] pre-bootoloader image

Just tried that, but without changed result.

Currently I am trying to get my PEEDI JTAG probe working with the
board, but until then I stay in the dark.


More information about the barebox mailing list