Compilation ath10k

Kalle Valo kvalo at
Tue Mar 25 03:31:38 EDT 2014

Vu Hai NGUYEN <vh.nguyen at> writes:

> Thak you Valo for your response,  i'm doing an internship and my mission is replacing 
> the module wifi WLE350NX (used chipset of Atheros and satisfied the standard 802.11n) by the new one
> WLE900VX to satisfy the standard 802.11ac for a router. Our actual driver is bought from Atheros (Driver Aquila)
> and i have to replace that driver by ath10k. I tried to compile it from the menuconfig of our code but it has many errors (you can see from the attached file).
> Then I try to compile in backport as you said, I was on the step 8 ( and get this error but I don't really understand it:
> /--------------
> | You shouldn't run make in the backports tree, but only in
> | the generated output. This here is only the skeleton code
> | copied into the output directory. To use the backport system
> | from scratch, go into the top-level directory and run
> |	./ /path/to/linux-next/ /tmp/output
> | and then make menuconfig/... in the output directory. See
> |	./ --help
> | for more options.
> \--
> make[1]: *** [modules] Error 1
> make: *** [default] Error 

Normal users should not run, instead it's recommended to take
official backports releases. I noticed that the wiki page was a bit
confusing and I tried to improve it a bit:

Here are simple instructions how to install ath10k from a backports release:

Download latest backports release and unpack it.
Run defconfig for ath10k:
make defconfig-ath10k
Compile backports:
Install backports:
sudo make install
Reboot system and ath10k should load automatically.
See backports documentation for more info.

Kalle Valo

More information about the ath10k mailing list