Ubuntu 17.10 GUI problem when connecting to Juniper/Pulse VPN

Peter Papp peter.papp.p at gmail.com
Thu Nov 2 05:33:16 PDT 2017

Hi Dan,

Thank you for your time on this.

I didn't build OpenConnect, I installed it with simple "apt install" on 
Ubuntu 17.10. I have no PPAs or any other extra software sources added, 
only what comes with a fresh Ubuntu install.

sudo apt install openconnect
sudo apt install network-manager-openconnect
sudo apt install network-manager-openconnect-gnome

openconnect --version

OpenConnect verzió: v7.08
GnuTLS használata. A következő jellemzői vannak: PKCS#11, RSA software 
token, HOTP software token, TOTP software token, Yubikey OATH, System 
keys, DTLS

(sorry it's in Hungarian but you understand the important part)

dpkg -l | grep openconnect

ii libopenconnect5:amd64             7.08-1  amd64 open client for Cisco 
AnyConnect VPN - shared library
ii network-manager-openconnect       1.2.4-1 amd64 network management 
framework (OpenConnect plugin core)
ii network-manager-openconnect-gnome 1.2.4-1 amd64 network management 
framework (OpenConnect plugin GNOME GUI)
ii openconnect                       7.08-1  amd64 open client for Cisco 
AnyConnect VPN

Hope this helps. Anything else I can do please let me know.

Thank you

2017-11-02 01:19 keltezéssel, Daniel Lenski írta:
> On Wed, Nov 1, 2017 at 6:42 PM, Peter Papp <peter.papp.p at gmail.com> wrote:
>> I am trying to connect to my job's Juniper VPN via openconnect. It works just fine in the terminal. I also installed the plugins and added the connection to NetworkManager GUI. When I want to connect, it gets the login form, which contains a domain selector drop-down. The problem is, I can not select what I want. The options are there, but when I click my selection, it gets reset (first option becomes selected again) and the focus jumps on the next field. I tried using the keyboard, tried filling out the rest of the form first, but to no avail. I also noticed that every time I pull down the list, a new icon appears on the launch bar.
> I can confirm this bug. I noticed it a few months ago and meant to
> report it, but see below for why I didn't… ¯\_(ツ)_/¯
> The Juniper realm dropdown box ("authgroup" in openconnect-internal
> parlance) can't be modified when connecting to a Juniper VPN via the
> OpenConnect NM GUi plugin. If I try to change the realm, it snaps back
> to the previous value just as Peter describes. Screenshot showing the
> offending UI element: https://snag.gy/ZGfOWJ.jpg
> Strangely, this problem does *not* apply to AnyConnect-protocol VPNs,
> even though I know the form is stored internally in an identical
> format.
> Even more strangely, I'm pretty sure that *I'm the one who added
> multi-protocol support to the nm-oc GUI*. (See
> https://git.gnome.org/browse/network-manager-openconnect/commit/?id=f58893e15fc7bac199f5afa95287f5101b6cbdb0).
> And there has not yet been a release of OpenConnect containing the API
> changes, nor of the NM GUI plugin changes using that new API.
> Peter, can you specify which (presumably pre-release) version of
> OpenConnect and the NM plugin you're running and where you built them
> from?
> -Dan

More information about the openconnect-devel mailing list