Ubuntu 17.10 GUI problem when connecting to Juniper/Pulse VPN

Daniel Lenski dlenski at gmail.com
Wed Nov 1 22:19:10 PDT 2017

On Wed, Nov 1, 2017 at 6:42 PM, Peter Papp <peter.papp.p at gmail.com> wrote:
> I am trying to connect to my job's Juniper VPN via openconnect. It works just fine in the terminal. I also installed the plugins and added the connection to NetworkManager GUI. When I want to connect, it gets the login form, which contains a domain selector drop-down. The problem is, I can not select what I want. The options are there, but when I click my selection, it gets reset (first option becomes selected again) and the focus jumps on the next field. I tried using the keyboard, tried filling out the rest of the form first, but to no avail. I also noticed that every time I pull down the list, a new icon appears on the launch bar.

I can confirm this bug. I noticed it a few months ago and meant to
report it, but see below for why I didn't… ¯\_(ツ)_/¯

The Juniper realm dropdown box ("authgroup" in openconnect-internal
parlance) can't be modified when connecting to a Juniper VPN via the
OpenConnect NM GUi plugin. If I try to change the realm, it snaps back
to the previous value just as Peter describes. Screenshot showing the
offending UI element: https://snag.gy/ZGfOWJ.jpg

Strangely, this problem does *not* apply to AnyConnect-protocol VPNs,
even though I know the form is stored internally in an identical

Even more strangely, I'm pretty sure that *I'm the one who added
multi-protocol support to the nm-oc GUI*. (See
And there has not yet been a release of OpenConnect containing the API
changes, nor of the NM GUI plugin changes using that new API.

Peter, can you specify which (presumably pre-release) version of
OpenConnect and the NM plugin you're running and where you built them


More information about the openconnect-devel mailing list