OCServ not starting TLS connection?

Wei Wang ww at 9rivers.com
Tue Dec 12 17:56:03 PST 2017

I built ocserv 0.11.9 from source on a Raspberry Pi. But when I
connect to it using Cisco AnyConnect, I get a bright red pop-up with
the title "Untrusted Server Blocked!".

I used openssl to connect to the server, the result shows that there is no TLS:
$ openssl s_client -connect localhost:7443
no peer certificate available
No client certificate CA names sent
SSL handshake has read 0 bytes and written 176 bytes
Verification: OK
New, (NONE), Cipher is (NONE)
Secure Renegotiation IS NOT supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
    Protocol  : TLSv1.2
    Cipher    : 0000
    PSK identity: None
    PSK identity hint: None
    SRP username: None
    Start Time: 1512487392
    Timeout   : 7200 (sec)
    Verify return code: 0 (ok)
    Extended master secret: no

I tried using client certificate to connect and got the same error.

Have I missed something obvious?

Thank you for any pointers.

Wei Wang

More information about the openconnect-devel mailing list