As easy as in Android???? Hopefully...

Nicolás Escudero nicolasescudero at
Sat Mar 28 23:24:02 PDT 2015


I'm experiencing the exact same issue posted on the original thread
from KajMagnus:

In short, I'm getting these 4 lines repeatedly over and over forever
no matter what arguments or wrapper I use:

SSL negotiation with
Connected to HTTPS on
Refreshing +CSCOE+/sdesktop/wait.html after 1 second...

Tried everything, with/without wrapper, --no-xml-post, binaries, all
same hard work and reasearch KajMagnus did, same poor luck.

I'm running openconnect v6.00, on a RaspberryPi running raspbian Jessie.

In the other hand, I'm perfectly able to connect to the same server
using both Windows Anyconnect and Android Openconnect. Both of them
with 100% default settings, just entered server+username and then,
when prompted, the passcode from my RSA Hard-Token.

COLOR NOTE: I cannot connect using AnyConnect for Android, I'm getting
a server response saying the server doesn't have an active "Mobile

So, As KajMagnus said :

> So I think there were two problems causing the weird error messages:
> 1) Linux not supported, and 2) wrong certificate.

I think I don't have a certificate issue, since I'm not using one when
connecting from Win or Android.

How can I emulate/mimic/replicate the Android openconnect client
behavior so I can connect from my Raspberry as easy as I'm doing in
android??? I insist I just installed the Client APK on my Galaxy S3,
opened it, used all default settings, entered just the server and
username and it worked like a charm at the first attempt.

This is my Server's /CACHE/sdesktop/data.xml:

Any help would be greatly appreciated!!
Thanks in advance, you are awesome!

More information about the openconnect-devel mailing list