ocserv 0.0.1 release

Nikos Mavrogiannopoulos nmav at gnutls.org
Mon Feb 25 15:19:51 EST 2013

On 02/25/2013 02:57 PM, Jason Cooper wrote:

> On Sat, Feb 23, 2013 at 08:04:55PM +0100, Nikos Mavrogiannopoulos wrote:
>> On 02/23/2013 07:40 PM, Jason Cooper wrote:
>>> for ocserv_0_0_1:
>>> autoreconf2.50: Entering directory `.'
>>> autoreconf2.50: configure.ac: not using Gettext
>>> autoreconf2.50: running: aclocal --force -I gl/m4 -I libopts/m4 -I m4
>> Just ignore then the autoreconf step and just run ./configure on that.
> checking for a BSD-compatible install... /usr/bin/install -c
> checking whether build environment is sane... yes
> checking for a thread-safe mkdir -p... /bin/mkdir -p
> checking for gawk... no
> checking for mawk... mawk
> checking whether make sets $(MAKE)... yes
> checking for gcc... gcc
> checking whether the C compiler works... yes
> checking for C compiler default output file name... a.out
> checking for suffix of executables...
> checking whether we are cross compiling... no
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> checking whether gcc accepts -g... yes
> checking for gcc option to accept ISO C89... none needed
> checking for style of include used by make... GNU
> checking dependency style of gcc... gcc3
> checking how to run the C preprocessor... gcc -E
> checking for grep that handles long lines and -e... /bin/grep
> checking for egrep... /bin/grep -E
> checking for Minix Amsterdam compiler... no
> checking for ar... ar
> checking for ranlib... ranlib
> configure: error: cannot run /bin/bash build-aux/config.sub
> meh.  The requested file isn't present.  This output is for
> ocserv_0_0_1, same or similar error for ToT.

I don't know why is that. When I run "autoreconf -fvi" and this file is
missing I get:
configure.ac:11: installing `build-aux/config.sub'

> Do you really *need* autohell?  Your only external dependencies seem to
> be gnutls, seccomp, and pam.  It might be a good idea to rip it out and
> only add it in when folks start complaining that they can't build on
> system X.

That folk happened to be me :) I tried to compile an initial version of
ocserv on my uclibc-based systems and I had to use configure to check
for libraries and features.


More information about the openconnect-devel mailing list