Getting started

Paul Floyd paulf at
Wed Dec 9 17:22:33 EST 2009


At work, we're moving our remote access to use Cisco AnyConnect.

In the past I did manage to get vpnc to work on FreeBSD, and to almost 
work on Solaris (can't remember if it was OpenSolaris or Solaris 10, 
either way, I could connect, but the split routing didn't work).

Anyway, I've just been through the AnyConnect rigmarole to get a 
certificate and get connected on Windows. I'd rather not be forced to 
use Windows though, not use the nasty looking bits that Cisco installed. 
I'd prefer to use Solaris or Mac.

On OpenSolaris, I've compiled and installed tun, compiled and installed 
openconnect. After that the instructions start getting a bit thin on the 
ground. I've tried jailbreak, and found one Client Authentication 
certificate. When I try to export it, it says it's marked as not 
exportable and won't export the private key. Is that right? Next, there 
are a choice of 3 formats, with DER as the default. Does it matter which 
one I choose?

I've tried the 1st and 3rd options when exporting, to get a .CER and a 
.PK7 file, and in both cases openconnect gives me a message that 
"Loading certificate failed".

Any help welcome!

Paul Floyd       

More information about the openconnect-devel mailing list