[PATCH v1 4/7] soc: starfive: Add pmu type operation
Changhuang Liang
changhuang.liang at starfivetech.com
Tue Apr 11 23:42:40 PDT 2023
On 2023/4/12 4:52, Conor Dooley wrote:
> Hey Changhuang Liang,
>
> On Mon, Apr 10, 2023 at 11:47:40PM -0700, Changhuang Liang wrote:
>> Add pmu type, make a distinction between different PMU.
>
> Please write more detailed commit messages, thanks.
>
OK, will write more detail for it.
>>
>> Signed-off-by: Changhuang Liang <changhuang.liang at starfivetech.com>
>> ---
>> drivers/soc/starfive/jh71xx_pmu.c | 55 ++++++++++++++++++++++---------
>> 1 file changed, 39 insertions(+), 16 deletions(-)
>>
>> diff --git a/drivers/soc/starfive/jh71xx_pmu.c b/drivers/soc/starfive/jh71xx_pmu.c
>> index 306218c83691..98f6849d61de 100644
>> --- a/drivers/soc/starfive/jh71xx_pmu.c
>> +++ b/drivers/soc/starfive/jh71xx_pmu.c
>> @@ -45,6 +45,12 @@
>> */
>> #define JH71XX_PMU_TIMEOUT_US 100
>>
>> +/* pmu type */
>
> Delete this comment, it's obvious.
>
OK, will delete this line.
>> +enum pmu_type {
>> + JH71XX_PMU_GENERAL,
>
> I'm really not sold on GENERAL as a name.
> Why not name these after the compatibles?
>
OK, will change to "JH71XX_PMU".
>> + JH71XX_PMU_DPHY,
>> +};
>> +
>> struct jh71xx_domain_info {
>> const char * const name;
>> unsigned int flags;
>> @@ -54,6 +60,7 @@ struct jh71xx_domain_info {
>> struct jh71xx_pmu_match_data {
>> const struct jh71xx_domain_info *domain_info;
>> int num_domains;
>> + u8 pmu_type;
>
> This is an enum, not a u8?
>
OK, will fix it.
> Thanks,
> Conor.
>
More information about the linux-riscv
mailing list