[PATCH v1 4/7] soc: starfive: Add pmu type operation
Conor Dooley
conor at kernel.org
Tue Apr 11 13:52:33 PDT 2023
Hey Changhuang Liang,
On Mon, Apr 10, 2023 at 11:47:40PM -0700, Changhuang Liang wrote:
> Add pmu type, make a distinction between different PMU.
Please write more detailed commit messages, thanks.
>
> Signed-off-by: Changhuang Liang <changhuang.liang at starfivetech.com>
> ---
> drivers/soc/starfive/jh71xx_pmu.c | 55 ++++++++++++++++++++++---------
> 1 file changed, 39 insertions(+), 16 deletions(-)
>
> diff --git a/drivers/soc/starfive/jh71xx_pmu.c b/drivers/soc/starfive/jh71xx_pmu.c
> index 306218c83691..98f6849d61de 100644
> --- a/drivers/soc/starfive/jh71xx_pmu.c
> +++ b/drivers/soc/starfive/jh71xx_pmu.c
> @@ -45,6 +45,12 @@
> */
> #define JH71XX_PMU_TIMEOUT_US 100
>
> +/* pmu type */
Delete this comment, it's obvious.
> +enum pmu_type {
> + JH71XX_PMU_GENERAL,
I'm really not sold on GENERAL as a name.
Why not name these after the compatibles?
> + JH71XX_PMU_DPHY,
> +};
> +
> struct jh71xx_domain_info {
> const char * const name;
> unsigned int flags;
> @@ -54,6 +60,7 @@ struct jh71xx_domain_info {
> struct jh71xx_pmu_match_data {
> const struct jh71xx_domain_info *domain_info;
> int num_domains;
> + u8 pmu_type;
This is an enum, not a u8?
Thanks,
Conor.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 228 bytes
Desc: not available
URL: <http://lists.infradead.org/pipermail/linux-riscv/attachments/20230411/08450102/attachment.sig>
More information about the linux-riscv
mailing list