[Linux-parport] ppscsi will not insert in kernel 2.6.13

Dion van Oirschot dion.van.oirschot at telenet.be
Sat Oct 15 06:27:42 EDT 2005

Hello and thanks for the quick response, this gives me hope,

The only thing is, I am still a newby. I tried to apply the fix to the 
module but to be honest, I don't really know what I am doing. I tried to 
compile the original module the 'Debian way' as described (downloading 
the deb package with apt-get and then with module-assistent). But now I 
suppose I have to work from source? I have found out I can download the 
source-code of the original patch with 'apt-get source ppscsi-source'. I 
put the source code in /tmp/ppscsi. But now I am totally lost. Here is 
some output from what is is in /tmp/ppscsi:

Dion at Dell:/tmp/ppscsi$ ls
ppscsi-0.3  ppscsi_0.3.dsc  ppscsi_0.3.tar.gz
Dion at Dell:/tmp/ppscsi/ppscsi-0.3$ ls
README.ppscsi  addons  debian  upstream

Dion at Dell:/tmp/ppscsi/ppscsi-0.3$ cd addons
Dion at Dell:/tmp/ppscsi/ppscsi-0.3/addons$ ls
Makefile  hosts.h  scsi.h  scsi_module.c  scsi_obsolete.h  scsi_typedefs.h

Dion at Dell:/tmp/ppscsi/ppscsi-0.3/addons$ cd ..
Dion at Dell:/tmp/ppscsi/ppscsi-0.3$ cd debian
Dion at Dell:/tmp/ppscsi/ppscsi-0.3/debian$ ls
README.Debian  control.modules.in  kernel-patch-ppscsi-2.6.kpatches
changelog      copyright           
compat         dirs                ppscsi-source.dirs
control        docs                rules

Dion at Dell:/tmp/ppscsi/ppscsi-0.3/debian$ cd ..
Dion at Dell:/tmp/ppscsi/ppscsi-0.3$ cd upstream
Dion at Dell:/tmp/ppscsi/ppscsi-0.3/upstream$ ls
linux-ppscsi-2.6.9.patch       linux-ppscsi-2.6.9.patch.rej
linux-ppscsi-2.6.9.patch.orig  linux-ppscsi-2.6.x.patch

I have no clue to which file to apply the patch now.
A friend of mine told me to use:

patch -sp1 < patchfile but what would be the patchfile?

I also downloaded the new patch in the /home/Dion/My Downloads dir (the 
.bin file) and used bunzip2 to unpack it to
/home/Dion/My Downloads/linux-ppscsi-2.6.9.patch-0001.bin.out  (bunzip2 
said: no filename to name the unpacked file, so using .out)

That is where I am now. What are the next steps if I want to build the 
patched patch as a module?

Thanks for any help!



Adam Baker wrote:

>The affected file hasn't changed since 2.6.11 and I've applied the patch to 
>2.6.11 and successfully got ppscsi talking to a slightly different model of 
>Mictotek Phantom so |'d say a qualified yes.
>You need to rebuild the parport module after applying the fix (assuming 
>parport is compiled as a module).

More information about the Linux-parport mailing list