RFC: Add module parameter to override regioncode?

Johan Adolfsson Johan.Adolfsson at axis.com
Fri Jun 6 09:03:19 EDT 2008

----- Original Message ----- 
From: "Dan Williams" <dcbw at redhat.com>
To: "Holger Schurig" <hs4233 at mail.mn-solutions.de>
Cc: "Johan Adolfsson" <johana at axis.com>; <libertas-dev at lists.infradead.org>
Sent: Friday, June 06, 2008 1:35 PM
Subject: Re: RFC: Add module parameter to override regioncode?

>> The removal and addition of those "priv->fwrelease >> xx & 0xff"
>> lines looks like a whitespace-changing patch. Does your patch
>> survive scripts/checkpatch.pl?
> In general whitespace shouldn't be changed unless it was wrong to begin
> with.

Yes, I'll fix that.

>> > --- a/drivers/net/wireless/libertas/main.c
>> > +++ b/drivers/net/wireless/libertas/main.c
>> Maybe you name your module parameter "libertas_regioncode", so
>> that it harmonizes with "libertas_debug". But no strong feeling
>> about this ...  :-)
> I'd rather have "region", or whatever mac80211 drivers might use.  I
> also would rather have "debug" instead of "libertas_debug".  Having the
> libertas_ is just redundant.

> Dan

Anybody that knows if the regioncodes used in libertas and 
Marvell driver is "standard" in some way?
If not, I think regioncode or region_code should still be used,
"region" is to generic I think, and implies something more 
human readable:
I.e region=US vs regioncode=0x10 or region_code=0x10
But that mapping could be done in usersspace if desired.

So what is the preference of the colour of the bikeshed:

Best regards

More information about the libertas-dev mailing list