Fwd: Kexec support for PS3 (ppc64)

Rajasekaran P rajasekaran83 at gmail.com
Fri Mar 14 06:36:58 EDT 2008

On Tue, Mar 11, 2008 at 11:48 AM, Geoff Levand <geoffrey.levand at am.sony.com>

> Geoff Levand wrote:
> Just FYI, I tried this and the kernel booted:
> ./kexec -l -t elf-ppc64 --append='crashkernel=64M at 32M root=/dev/nfs rw
> ip=dhcp video=wuxga' /boot/vmlinux.strip
> I saw this output:
> kexec: waiting for cpu 1 (physical 1) to go down
> Reserving 64MB of memory at 32MB for crashkernel (System RAM: 128MB)
> ...
> Kernel command line: crashkernel=64M at 32M root=/dev/nfs rw ip=dhcp
> video=wuxga
> -Geoff
> This works properly. Thanks Geoff.

Initially I made mistake by referring /proc/meminfo and thought the total
RAM was > 200M iB (actually it shows around 211MiB in /proc/meminfo
excluding swap space). But actual available memory is 128MiB only. Thats why
reserving 128MiB on 32MiB failed and kernel was not booting up.

Now "crashkernel" argument works properly for 64MB at 64MB and kernel reserves
64MB for crash dump capture kernel.

This memory is reserved for "dump capture kernel" which will be loaded later
by using kexec. Please refer linux_src/Documentation/kdump/kdump.txt for
more information.

I tried to load dump capture configured kernel and facing similar kind of
problem. After successful loading, Dump capture kernel is NOT BOOTING UP
upon kernel crash.
I used the following command to load:

# kexec -t elf-ppc64 --append="video=ps3fb:mode:166 rhgb root=/dev/ps3da3
single maxcpus=1 noirqdistrib" \
 --initrd=/boot/initrd-2.6.23-kdump.img \
 -p vmlinux.strip.kdump
*setup_memory_ranges memory_range[0] start:585001, end:8000000
get memory ranges:1
setup_memory_ranges memory_range[0] start:585001, end:8000000
Modified cmdline:video=ps3fb:mode:166 rhgb root=/dev/ps3da3 single maxcpus=1
noirqdistrib elfcorehdr=71068K savemaxmem=64M
segment[0].mem:0x4000000 memsz:5599232
segment[1].mem:0x4557000 memsz:65536
segment[2].mem:0x4567000 memsz:4096
segment[3].mem:0x4568000 memsz:36864
segment[4].mem:0x4571000 memsz:3469312
segment[5].mem:0x7fff000 memsz:4096
One more thing I confirmed was, this same dump capture kernel boots up
properly when I load it on normal mode (kexec -l and then kexec -e). I am
having no clue on this..

If anybody know how to debug a kernel failure during boot up, it will be
very helpful. Please help.

Thanks in advance,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.infradead.org/pipermail/kexec/attachments/20080314/7c0ebd6b/attachment.html 

More information about the kexec mailing list