wpasupplicant and WEP

Sajjad Rehman sajjad.rehman
Tue Dec 30 05:24:21 PST 2014

Is wep still supported on 11n? I think there was plan to deprecate it..

Sent from my Windows PhoneFrom: Erich Titl
Sent: ?30/?12/?2014 13:16
To: hostap at lists.shmoo.com
Subject: wpasupplicant and WEP
Hello everybody

I tried the mailing list archives for this subject, some information is
there but nothing really helped.

I am trying to implement a WLAN client on an embedded platform. I am
using wpasupplicant to manage the connection parameters and so far
everything works fine with the exception of WEP based (in)security.

When connecting to a WEP based AP I am getting status COMPLETED, so it
appears as if the connection was established at the network level, but
then dhcpcd sends a broadcast to obtain a lease, this broadcat is then
received and replied to by the dhcp server, but looking with tcpdump at
the wlan0 interface the reply never reaches the adapter. Using WPA
everything works fine.

I tried with ath5k and b43 network adapters/drivers

Any insight is apreciated


More information about the Hostap mailing list