wpasupplicant and WEP

Erich Titl erich.titl
Tue Dec 30 05:16:55 PST 2014

Hello everybody

I tried the mailing list archives for this subject, some information is
there but nothing really helped.

I am trying to implement a WLAN client on an embedded platform. I am
using wpasupplicant to manage the connection parameters and so far
everything works fine with the exception of WEP based (in)security.

When connecting to a WEP based AP I am getting status COMPLETED, so it
appears as if the connection was established at the network level, but
then dhcpcd sends a broadcast to obtain a lease, this broadcat is then
received and replied to by the dhcp server, but looking with tcpdump at
the wlan0 interface the reply never reaches the adapter. Using WPA
everything works fine.

I tried with ath5k and b43 network adapters/drivers

Any insight is apreciated


-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 1908 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.shmoo.com/pipermail/hostap/attachments/20141230/7231f343/attachment.bin>

More information about the Hostap mailing list