Certificate verification failed, error 19 (self signed certificate in certificate chain)

Jouni Malinen j
Sun Apr 1 12:38:35 PDT 2012

On Sun, Apr 01, 2012 at 04:43:06PM +0100, Michael Zintakis wrote:
> > That sounds quite strange.. Would it be possible to get a detailed debug
> > log (-ddt on wpa_supplicant command line) showing this?
> >   
> I am going to have some problems with that, because Android is running 
> the wpa_supplicant with a fixed command line - 
> "/system/bin/wpa_supplicant -Dtiwlan0 -itiwlan0 
> -c/data/misc/wifi/wpa_supplicant.conf -q" - and when I try to run this 
> from the command line (via adb) I fail, quite miserably!
> I also tried to do this via wpa_cli, but every time I execute "wpa_cli 
> level XX", where XX is a number (I tried 2,5,99) I get this:

wpa_cli level is not the correct command to use here.. Depending on the
wpa_supplicant version used here, you could be able to change the debug
log verbosity (i.e., what gets sent to Android logcat) with wpa_cli
log_level command. That may take in a number or a string like DEBUG
depending on which version is used here.

> On the slightly bright side, I am able to reproduce the problem I 
> described previously quite easily by executing "wpa_cli reassociate" 
> once I am connected - I get these errors instantly in the android logs, 
> but the frustrating thing is that I can't alter the debug level to see more!

OK, so good to know that it is at least easy to reproduce. Which
wpa_supplicant and Android versions are you using?

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list