Hostapd and ath9k - AP not working

Helena Zhang helena
Tue Mar 24 03:07:36 PDT 2009


I've been trying to set up hostapd with ath9k driver but it's not working.
I'm using kernel cross compiled for powerpc. Ath9k in station mode
works fine, but other stations do not see the ap when I set it up in ap

my hostapd.conf:

when I run hostapd -dB hostapd.conf
Configuration file: hostapd.conf
Opening raw packet socket for ifindex 1208054188
BSS count 1, BSSID mask ff:ff:ff:ff:ff:ff (0 bits)
SIOCGIWRANGE: WE(compiled)=22 WE(source)=21 enc_capa=0xf
nl80211: Added 802.11b mode based on 802.11g information
RATE[0] rate=10 flags=0x2
RATE[1] rate=20 flags=0x2
RATE[2] rate=55 flags=0x0
RATE[3] rate=110 flags=0x0
Passive scanning not supported
Flushing old station entries
Deauthenticate all stations
Using interface wlan0 with hwaddr 00:0b:6b:b0:04:62 and ssid 'test'
wlan0: Setup of interface done.

Which looks normal. The one issue is that the essid is not set to 'test' and
remains blank when I run iwconfig. I can set the essid via iwconfig, but it
doesn't do anything to help the big problem. Basically, there are no errors
but stations do not see the ap at all when they scan for it. Any help would
be most welcome - I've been stuck for quite a while.
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Hostap mailing list