wpa_supplicant donot conneect with TTLS in debian/testing

Jouni Malinen j
Tue Mar 18 03:29:20 PDT 2008

On Tue, Mar 18, 2008 at 11:08:38AM +0100, Jos? Luis wrote:

> Since I have upgraded my laptop with debian/testing, muy wireless
> netweork do not connect.

Are you saying that it worked before the upgrade? What version were you
using before the upgrade?

> My conf file for wpa_supplicant is:

> network={
>         ssid="pdi"
>         proto=WPA
>         key_mgmt=WPA-EAP
>         pairwise=TKIP
>         eap=TTLS
>         identity="****"
>         password="****"
> }

Did you change this or are you still using the exact same configuration
file? EAP-TTLS may require configuration of a specific phase 2
(tunneled) authentication method. Are you sure this is not needed for
the network?

> When I start wpa_supplicant it show next message:
> Trying to associate with SSID 'pdi'
> Associated with 00:13:c4:8b:08:15
> CTRL-EVENT-EAP-STARTED EAP authentication started
> CTRL-EVENT-EAP-METHOD EAP vendor 0 method 21 (TTLS) selected
> OpenSSL: tls_connection_handshake - Failed to read possible Application
> Data error:00000000:lib(0):func(0):reason(0)
> CTRL-EVENT-EAP-FAILURE EAP authentication failed

Could you please send more detailed debug log (add -dd to the command

> What could I do? I cannot downgrade libssl to debian/stable without
> downgrade all the system. I have tried to use the unstable version of
> these programs but they do not connect.

Do you have any particular reason to believe that the issue is related
to the OpenSSL version?

> I have read in google that this is a problem of libssl0.9.8g2 and could
> be solve with libssl0.9.8g3, but in debian/testing it is libssl.9.8.g4.

Could you please provide specific pointers to web pages that describe
this problem in more detail?

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list