Fwd: Messed up PCMCIA firmware

Pavel Roskin proski
Sun Aug 3 19:29:03 PDT 2008

Quoting Madhusudan Singh <singh.madhusudan at gmail.com>:

> On Mon, Jul 21, 2008 at 1:28 PM, Pavel Roskin <proski at gnu.org> wrote:
>> Why did you need to override the path to pda?  From what I see in the
>> code of hostap-utils-0.4.7, it should not be needed.
>  I am not using the latest version of hostap. My version :
>  $ sudo apt-cache policy hostap-utils
> hostap-utils:
>   Installed: 1:0.4.0-1
>   Candidate: 1:0.4.0-1
>   Version table:
>  *** 1:0.4.0-1 0
>         500 http://us.archive.ubuntu.com hardy/universe Packages
>         100 /var/lib/dpkg/status
> I will try out the new version, but I am not convinced that that is my
> problem. At least not yet.

I'm not going to convince you of anything.  New versions are released  
to fix known problems.  If you are using an older version, chances are  
that you will encounter those problems.  If you are using the latest  
version, you are more likely to get a useful reply.

>> You need flashable primary firmware that starts with "pk" (like
>> pl010101.hex) and flashable secondary firmware that starts with
>> "sf" (sf010704.hex for 1.7.4 firmware).
>  I have tried that with various pk* and sf* files on junsun website. It does
> not work. I have even downloaded the version from netgear's own website :
>  http://kbserver.netgear.com/products/MA401.asp
> version 2 on the left pane has a firmware folder when expanded (this is
> firmware 1.3.4).
> $ sudo prism2_srec -vv -f wlan0 P40003C0.HEX S1010304.HEX

I believe it's firmware for older hfa3841 devices.

> Verifying update compatibility and combining data:
> NICID was not found from the list of supported platforms.
> Incompatible update data.

And prism2_srec confirms it.

> I have a different error (IOCTL etc.) when I try the above without
> downloading anything to the RAM.
> This makes no sense. This is firmware from the card's own driver set.

The driver can include firmware for older revisions.

> Second - I even found an old windows XP laptop and tried using winupdate
> (both the version that comes with the netgear 2.0 drivers above and the
> latest version 0.7.0). When I install the windows XP drivers manually or
> allow windows XP to install the drivers, I get an error message stating that
> card could not be started and neither version of winupdate is able to find
> the adapter.
> Any ideas ?

I guess it's because you damaged the firmware in the card.

> PS : As I mentioned, I will try the latest version of hostap-utils if you
> insist but I do not think that the problem lies there.

I'm not going to spend time convincing you or research which changes  
can affect your case.  I have other things to do.

Pavel Roskin

More information about the Hostap mailing list