Not using modified module

ahuguet at ahuguet
Thu Apr 12 06:48:13 PDT 2007

> try explicitly adding
> "INSTALL_MOD_DIR=/lib/modules/"
> to your modules_install command.

Hi Bob,
first of all thank you once again for your will to help.
I did try adding this on all imaginable places at the modules_install
command, to no avail. Furthermore, it seems the command is utterly
ignored, and Linux placed the updater .ko files not on extra folder, but
on the hostap source folder. Why it did this, is something I don't

On the other hand, I checked the file you mention, and it indeed seems
that only those modules outside the kernel tree should go to extra, so I
don't understand why hostap modules are thrown there. Maybe it has to do
with pcmcia module, I don't know.

So, what I ended up doing was the following:

Since running the modules_install command without the INSTALL_MOD_DIR left
the .ko files in extra folder, I copied the .ko files from the extra
folder to the lib/modules/*version*/kernel/drivers/net/.../hostap and that
worked, as I wrote on an earlier post, thus:

I made myself a script, that goes through steps
1) 2) and 3) (1 make modules, 2 make modules_install, 3 depmod -ae) and I
added a line that copies the .ko files in extra folder to the one I
mentioned earlier.
After that is done, I need to restart the system for the changes to apply.

It's a rude method to work with, I must say, but so far it's been the one
that has worked.

I might end up trying another computer, with another kernel distribution,
and maybe there I've better luck with module handling.

If I find problems there, I'll try asking for help here once again, and
I'll keep giving as much information as needed.

Thanks once again Bob. I do appreciate your effort.

More information about the Hostap mailing list