wpa_supplicant && mandriva 2007

Luis A. Montes luis.montes
Sun Oct 15 17:01:30 PDT 2006

engage wrote:
> I haven't been able to get WPA running since doing an upgrade to Mandriva 
> 2007. A fresh install of Mandriva didn't help either. I'm using a Linksys 
> WUSB54G which worked with Mandriva 2006 & ndiswrapper & Windows XP driver 
> rt2500usb. Mandriva 2007 wants to use the rtusb driver (alias rausb0 rtusb). 
> The card does show an association with the AP but I can't get it to use the 
> encryption. (All my other wireless devices are associating with the AP with 
> WPA) I searched the hard drive for the rtusb driver but only found a listing 
> under /sys. No matter what I try I can't get the USB device to use anything 
> other than rtusb. The only rt* driver I can find with lsmod is rt2570. 
You can use the /sys/bus/usb/drivers to see what drivers are associated
with which device.

> I 
> tried renaming all the rt drivers under /lib/modules with a .old extension 
> and then tried a reboot only to have my changes undone (the .old extension 
> was removed - yes, I did confirm that everything was renamed before the 
> reboot).
Maybe try "blacklisting" the module that's being associated with your
hardware. In ubuntu there is a /etc/modprobe.d/bad_list where you would
put a line like
alias rt2570 off
to prevent that particular module from loading.

> I tried to use ndiswrapper with the "help" of the MCC but it kept 
> telling me that the ndiswrapper interface couldn't be found. I tried to 
> modprobe ndiswrapper & ndiswrapper installed but the rt2500usb driver didn't 
> install (ndiswrapper -l shows the driver and hardware present) and no wlan0 
> showed up. I even tried removing the wpa_supplicant-0.5.x that came with 
> Mandriva 2007 and tried installing wpa_supplicant-0.4.9. Still no-go. I get a 
> LOT of ioct [SIO........]: Operation not supported. I'm executing: 
> wpa_supplicant -irausb0 -c/etc/wpa_supplicant.conf -B.  I don't know if this 
> is enough information help diagnose my problem. Googling hasn't turned up any 
> solutions yet either. The USB card does support WPA/WPA2, obviously, since it 
> worked with WPA2 in Mandriva 2006.
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap

Hope it helps. I'm just a user looking for answers as well, so take my
suggestions with a grain of salt.

More information about the Hostap mailing list